Commit 0c53d0aa authored by Ben Gamari's avatar Ben Gamari 🐢

configure: Determine library versions of template-haskell, et al.

These are needed by the user guide documentation. Fixes #17260.
parent 795986aa
......@@ -1317,8 +1317,14 @@ AC_SUBST(BUILD_MAN)
AC_SUBST(BUILD_SPHINX_HTML)
AC_SUBST(BUILD_SPHINX_PDF)
dnl ** Determine library versions
dnl The packages below should include all packages needed by
dnl doc/users_guide/ghc_config.py.in.
LIBRARY_VERSION(base)
LIBRARY_VERSION(Cabal, Cabal/Cabal)
LIBRARY_VERSION(template-haskell)
LIBRARY_VERSION(parallel)
LIBRARY_VERSION(array)
LIBRARY_VERSION(ghc-prim)
LIBRARY_VERSION(ghc-compact)
LIBRARY_ghc_VERSION="$ProjectVersion"
......
......@@ -4,6 +4,9 @@ extlinks = {
}
libs_base_uri = '../libraries'
# N.B. If you add a package to this list be sure to also add a corresponding
# LIBRARY_VERSION macro call to configure.ac.
lib_versions = {
'base': '@LIBRARY_base_VERSION@',
'ghc-prim': '@LIBRARY_ghc_prim_VERSION@',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment