Commit 8b5a06b8 authored by simonmar's avatar simonmar
Browse files

[project @ 2005-05-10 10:08:50 by simonmar]

-ignore-package lang if GHC >= 6.3, fixes build breakage if wxHaskell
 is installed.
parent 33b563b5
......@@ -496,6 +496,13 @@ SRC_HC_OPTS += -package Cabal
PKG_DEPENDS += Cabal
endif
ifeq "$(ghc_ge_603)" "YES"
# Ignore lang, to avoid potential clash with the Generics module if
# lang happens to be a dependency of some exposed package in the local
# GHC installation (eg. wxHaskell did this around 6.4).
SRC_HC_OPTS += -ignore-package lang
endif
SRC_CC_OPTS += -Iparser -I. -O
SRC_HC_OPTS += -recomp $(GhcHcOpts) $(GhcStage$(stage)HcOpts)
SRC_HC_OPTS += -H16M
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment