Commit caadd032 authored by panne's avatar panne

[project @ 2003-02-20 18:53:15 by panne]

* Nuked unused --with-glut-api and --with-glut-xlib arguments
* Only check for OpenGL headers and libs when --enable-hopengl is given
parent f9388d14
...@@ -532,26 +532,6 @@ AC_ARG_ENABLE(hopengl, ...@@ -532,26 +532,6 @@ AC_ARG_ENABLE(hopengl,
) )
AC_SUBST(GhcLibsWithHOpenGL) AC_SUBST(GhcLibsWithHOpenGL)
dnl ** Use a specific version of the GLUT API
dnl --------------------------------------------------------------
AC_ARG_WITH(glut-api,
[ --with-glut-api=<version>
Use a specific version of the GLUT API when building HOpenGL.
])
test -n "$with_glut_api" && CPPFLAGS="$CPPFLAGS -DGLUT_API_VERSION=$with_glut_api"
dnl ** Use a specific version of the GLUT API
dnl --------------------------------------------------------------
AC_ARG_WITH(glut-xlib,
[ --with-glut-xlib=<version>
Use a specific version of the GLUT Xlib implementation when building HOpenGL.
])
test -n "$with_glut_xlib" && CPPFLAGS="$CPPFLAGS -DGLUT_XLIB_IMPLEMENTATION=$with_glut_xlib"
dnl -------------------------------------------------------------- dnl --------------------------------------------------------------
dnl End of configure script option section dnl End of configure script option section
dnl -------------------------------------------------------------- dnl --------------------------------------------------------------
...@@ -1048,7 +1028,10 @@ mingw32) ;; ...@@ -1048,7 +1028,10 @@ mingw32) ;;
*) AC_PATH_XTRA() ;; *) AC_PATH_XTRA() ;;
esac esac
dnl ** check for OpenGL/GLUT/GLX include paths and libraries
if test $GhcLibsWithHOpenGL = YES ; then
FPTOOLS_HAVE_OPENGL FPTOOLS_HAVE_OPENGL
fi
dnl ################################################################ dnl ################################################################
dnl Check for libraries dnl Check for libraries
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment