Commit b81ad2a1 authored by Ben Gamari's avatar Ben Gamari 🐢

Upgrade ARM/AArch64 images to Buster

parent 92eeee3a
......@@ -51,19 +51,19 @@ build-linters:
- docker
- x86_64-linux
build-aarch64-linux-deb9:
build-aarch64-linux-deb10:
extends: .build
variables:
IMAGE: aarch64-linux-deb9
IMAGE: aarch64-linux-deb10
allow_failure: true
tags:
- docker
- aarch64-linux
build-armv7-linux-deb9:
build-armv7-linux-deb10:
extends: .build
variables:
IMAGE: armv7-linux-deb9
IMAGE: armv7-linux-deb10
allow_failure: true
tags:
- docker
......
FROM aarch64/debian:stretch
FROM arm64v8/debian:buster
ENV LANG C.UTF-8
......@@ -8,7 +8,7 @@ SHELL ["/bin/bash", "-o", "pipefail", "-c"]
RUN apt-get update \
&& apt-get install --no-install-recommends -qy zlib1g-dev libtinfo-dev libsqlite3-0 libsqlite3-dev \
ca-certificates g++ git make automake autoconf gcc \
perl python3 texinfo xz-utils pxz lbzip2 bzip2 patch openssh-client sudo time \
perl python3 texinfo xz-utils lbzip2 bzip2 patch openssh-client sudo time \
jq wget curl locales libnuma-dev \
# Documentation tools
python3-sphinx texlive-xetex texlive-latex-extra texlive-binaries texlive-fonts-recommended lmodern texlive-generic-extra \
......
FROM arm32v7/debian:stretch
FROM arm32v7/debian:buster
ENV LANG C.UTF-8
......@@ -9,7 +9,7 @@ RUN apt-get update \
&& apt-get install --no-install-recommends -qy zlib1g-dev libtinfo-dev libgmp10 libgmp-dev \
libsqlite3-0 libsqlite3-dev \
ca-certificates g++ git make automake autoconf gcc \
perl python3 texinfo xz-utils pxz lbzip2 bzip2 patch openssh-client sudo time \
perl python3 texinfo xz-utils lbzip2 bzip2 patch openssh-client sudo time \
jq wget curl locales \
# Documentation tools
python3-sphinx texlive-xetex texlive-latex-extra texlive-binaries texlive-fonts-recommended lmodern texlive-generic-extra \
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment