Commit 027f2825 authored by Ian Lynagh's avatar Ian Lynagh

Tidy up compiler/ghc.cabal.in

We now always have base4, and don't need a workaround for GHC 6.4.2.
parent 05710922
......@@ -20,12 +20,6 @@ Category: Development
Build-Type: Simple
Cabal-Version: >= 1.2.3
Flag base4
Description: Choose the even newer, even smaller, split-up base package.
Flag base3
Description: Choose the new smaller, split-up base package.
Flag dynlibs
Description: Dynamic library support
Default: False
......@@ -54,26 +48,20 @@ Flag stage3
Library
Exposed: False
if flag(base4)
Build-Depends: base >= 4 && < 5
if flag(base3)
Build-Depends: base >= 3 && < 4
if !flag(base3) && !flag(base4)
Build-Depends: base < 3
Build-Depends: base >= 4 && < 5,
directory >= 1 && < 1.2,
process >= 1 && < 1.2,
bytestring >= 0.9 && < 0.11,
time < 1.5,
containers >= 0.1 && < 0.6,
array >= 0.1 && < 0.5,
filepath >= 1 && < 1.4,
Cabal,
hpc
if flag(stage1) && impl(ghc < 7.5)
Build-Depends: old-time >= 1 && < 1.2
if flag(base3) || flag(base4)
Build-Depends: directory >= 1 && < 1.2,
process >= 1 && < 1.2,
bytestring >= 0.9 && < 0.11,
time < 1.5,
containers >= 0.1 && < 0.6,
array >= 0.1 && < 0.5
Build-Depends: filepath >= 1 && < 1.4
Build-Depends: Cabal, hpc
if os(windows)
Build-Depends: Win32
else
......@@ -89,10 +77,6 @@ Library
Build-Depends: bin-package-db
Build-Depends: hoopl
-- GHC 6.4.2 needs to be able to find WCsubst.c, which needs to be
-- able to find WCsubst.h
Include-Dirs: ../libraries/base/cbits, ../libraries/base/include
Extensions: CPP, MagicHash, UnboxedTuples, PatternGuards,
ForeignFunctionInterface, EmptyDataDecls,
TypeSynonymInstances, MultiParamTypeClasses,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment