Commit 087dbbed authored by Ben Gamari's avatar Ben Gamari 🐢

Bump Cabal submodule

We are now tracking the 2.0 branch.
parent 27a28541
Subproject commit 824d0bae1aee2a25cabdcef92e5e1dd470c7dac0
Subproject commit e8aa54220a4bbe3fe6d14542f3a94222228efb2f
Preprocessing library 'bkpcabal01-0.1.0.0-JzlnBa7joVSAwW36Ug1T14-p' for
bkpcabal01-0.1.0.0...
Preprocessing library 'bkpcabal01-0.1.0.0-JzlnBa7joVSAwW36Ug1T14-q' for
bkpcabal01-0.1.0.0...
Preprocessing library 'p' for bkpcabal01-0.1.0.0..
Building library 'p' instantiated with H = <H>
for bkpcabal01-0.1.0.0..
Preprocessing library 'q' for bkpcabal01-0.1.0.0..
Building library 'q' instantiated with H = <H>
for bkpcabal01-0.1.0.0..
Setup: The following packages are broken because other packages they depend on
are missing. These broken packages must be rebuilt before they can be used.
Error:
The following packages are broken because other packages they depend on are missing. These broken packages must be rebuilt before they can be used.
installed package q-1.0 is broken due to missing package p-noopt
Preprocessing executable 'test' for b-1.0...
Preprocessing executable 'test' for b-1.0..
Building executable 'test' for b-1.0..
[1 of 2] Compiling B ( B.hs, dist/build/test/test-tmp/B.o ) [A changed]
[2 of 2] Compiling Main ( Main.hs, dist/build/test/test-tmp/Main.o ) [B changed]
Linking dist/build/test/test ...
T10796b.hs:8:17: error:
Can't construct a pattern from name Data.Set.Base.fromList
In the untyped splice:
$(dataToPatQ (const Nothing) (fromList "test"))
Can't construct a pattern from name Data.Set.Base.fromList
In the untyped splice:
$(dataToPatQ (const Nothing) (fromList "test"))
......@@ -24,6 +24,6 @@ Executable check-api-annotations
Build-Depends: base >= 4 && < 5,
containers,
Cabal >= 1.25 && <1.27,
Cabal >= 2.0 && < 2.1,
directory,
ghc
......@@ -25,8 +25,7 @@ Executable check-ppr
Build-Depends: base >= 4 && < 5,
bytestring,
containers,
-- Cabal >= 1.25 && <1.27,
Cabal >= 1.24 && <1.27,
Cabal >= 2.0 && < 2.1,
directory,
filepath,
ghc
......@@ -21,7 +21,7 @@ Executable ghc-cabal
Build-Depends: base >= 3 && < 5,
bytestring >= 0.10 && < 0.11,
Cabal >= 1.25 && < 1.27,
Cabal >= 2.0 && < 2.1,
directory >= 1.1 && < 1.4,
filepath >= 1.2 && < 1.5
......@@ -54,7 +54,7 @@ $(ghc-cabal_DIST_BINARY): utils/ghc-cabal/Main.hs $(TOUCH_DEP) | $$(dir $$@)/. b
-no-user-$(GHC_PACKAGE_DB_FLAG) \
-Wall -fno-warn-unused-imports -fno-warn-warnings-deprecations \
-DCABAL_VERSION=$(CABAL_VERSION) \
-DMIN_VERSION_binary_0_8_0 \
-DHAVE_containers_050 \
-DBOOTSTRAPPING \
-optP-include -optPutils/ghc-cabal/cabal_macros_boot.h \
-odir bootstrapping \
......
......@@ -18,6 +18,6 @@ Executable ghctags
Build-Depends: base >= 4 && < 5,
containers,
Cabal >= 1.25 && <1.27,
Cabal >= 2.0 && <2.1,
ghc
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment