Commit 3efd1e99 authored by Ben Gamari's avatar Ben Gamari 🐢 Committed by Marge Bot
Browse files

template-haskell: Bump version to 2.20.0.0

Updates `text` and `exceptions` submodules for bounds bumps.

Addresses #22767.
parent fec7c2ea
Pipeline #61937 canceled with stages
in 27 seconds
......@@ -81,7 +81,7 @@ Library
containers >= 0.6.2.1 && < 0.7,
array >= 0.1 && < 0.6,
filepath >= 1 && < 1.5,
template-haskell == 2.19.*,
template-haskell == 2.20.*,
hpc == 0.6.*,
transformers >= 0.5 && < 0.7,
exceptions == 0.10.*,
......
Subproject commit 0f17c9819fd4216ac591bb0acc4aa71b2ae5a733
Subproject commit a473e4fa1acdbcfc7cc96f84ae3f2cb38261e08b
......@@ -79,7 +79,7 @@ library
filepath == 1.4.*,
ghc-boot == @ProjectVersionMunged@,
ghc-heap == @ProjectVersionMunged@,
template-haskell == 2.19.*,
template-haskell == 2.20.*,
transformers >= 0.5 && < 0.7
if !os(windows)
......
......@@ -3,7 +3,7 @@
-- template-haskell.cabal.
name: template-haskell
version: 2.19.0.0
version: 2.20.0.0
-- NOTE: Don't forget to update ./changelog.md
license: BSD3
license-file: LICENSE
......
Subproject commit 5558730e76923f2d5d7fbc8783ab1ecc25bfe15d
Subproject commit 197bbcb18977593a06b048ad58abe71c6119799e
......@@ -2,4 +2,4 @@
<no location info>: warning: [GHC-42258] [-Wunused-packages]
The following packages were specified via -package or -package-id flags,
but were not needed for compilation:
- template-haskell-2.19.0.0 (exposed by flag -package template-haskell)
- template-haskell-2.20.0.0 (exposed by flag -package template-haskell)
......@@ -3,5 +3,5 @@ T4806a.hs:1:1: error:
Could not load module ‘Data.Map’
It is a member of the package ‘containers-0.6.6’
which is unusable because the -ignore-package flag was used to ignore at least one of its dependencies:
deepseq-1.4.8.0 template-haskell-2.19.0.0
deepseq-1.4.8.0 template-haskell-2.20.0.0
Use -v (or `:set -v` in ghci) to see a list of the files searched for.
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment