Commit 5ad32b42 authored by panne's avatar panne
Browse files

[project @ 2004-12-04 14:07:25 by panne]

Moved GTK_CONFIG detection to ghc subdirectory (untested).
parent aa9c98ec
......@@ -1219,20 +1219,6 @@ else
AC_SUBST(HaveRtldNow)
fi
dnl --------------------------------------------------
dnl * test for GTK+
dnl --------------------------------------------------
AC_PATH_PROGS([GTK_CONFIG], [gtk-config gtk12-config])
if test -n "$GTK_CONFIG"; then
AC_CACHE_CHECK([for version of GTK+], [fp_cv_gtk_version],
[fp_cv_gtk_version=`$GTK_CONFIG --version`])
FP_COMPARE_VERSIONS([$fp_cv_gtk_version], [-lt], [1.2],
[AC_MSG_WARN([GTK+ not usable, need at least version 1.2])
GTK_CONFIG=])
fi
AC_SUBST([GTK_CONFIG])
dnl --------------------------------------------------
dnl * Miscellaneous feature tests
dnl --------------------------------------------------
......
......@@ -23,6 +23,17 @@ FP_GCC_NEEDS_NO_OMIT_LFPTR
# Check whether this GHC has readline installed
FP_GHC_HAS_READLINE
# test for GTK+
AC_PATH_PROGS([GTK_CONFIG], [gtk-config gtk12-config])
if test -n "$GTK_CONFIG"; then
AC_CACHE_CHECK([for version of GTK+], [fp_cv_gtk_version],
[fp_cv_gtk_version=`$GTK_CONFIG --version`])
FP_COMPARE_VERSIONS([$fp_cv_gtk_version], [-lt], [1.2],
[AC_MSG_WARN([GTK+ not usable, need at least version 1.2])
GTK_CONFIG=])
fi
AC_SUBST([GTK_CONFIG])
# Write the results...
AC_CONFIG_FILES([ghc.spec VERSION docs/users_guide/ug-book.xml mk/config.mk mk/version.mk])
AC_OUTPUT
# -*-makefile-*-
# @configure_input@
# -----------------------------------------------------------------------------
#
# GHC project configuration
......@@ -24,4 +26,7 @@ GhcBinDistLinks = ghc ghci ghc-pkg
# Set to YES if $(GHC) has the readline package installed
GhcHasReadline = @GhcHasReadline@
# GTK+
GTK_CONFIG = @GTK_CONFIG@
include $(GhcMainDir)/mk/version.mk
......@@ -762,11 +762,6 @@ HaveFrameworkHaskellSupport = @HaveFrameworkHaskellSupport@
#
HavePosixRegex = @HavePosixRegex@
#-----------------------------------------------------------------------------
# GTK+
GTK_CONFIG = @GTK_CONFIG@
#-----------------------------------------------------------------------------
# Flex (currently unused, could be moved to glafp-utils)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment