Commit 644090f6 authored by Ian Lynagh's avatar Ian Lynagh

Increase the requirements for the annotations tests from 6.9 to 6.11

parent 54bee08d
# Annotations were implemented in GHC 6.9 and not supported in other compilers
setTestOpts(if_compiler_lt('ghc', '6.9', skip));
# Annotations were implemented in GHC 6.11 and not supported in other compilers
setTestOpts(if_compiler_lt('ghc', '6.11', skip));
test('ann01', normal, compile, ['-v0'])
......
# Annotations were implemented in GHC 6.9 and not supported in other compilers
setTestOpts(if_compiler_lt('ghc', '6.9', skip));
# Annotations were implemented in GHC 6.11 and not supported in other compilers
setTestOpts(if_compiler_lt('ghc', '6.11', skip));
test('annfail01', normal, compile_fail, [''])
test('annfail02', normal, compile_fail, [''])
......
# Annotations were implemented in GHC 6.9 and not supported in other compilers
# Annotations were implemented in GHC 6.11 and not supported in other compilers
# These tests are very slow due to their use of package GHC
setTestOpts(compose(skip_if_fast, if_compiler_lt('ghc', '6.9', skip)));
setTestOpts(compose(skip_if_fast, if_compiler_lt('ghc', '6.11', skip)));
runCmd('$MAKE -C ' + in_testdir('') + ' config')
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment