Commit 78185538 authored by Duncan Coutts's avatar Duncan Coutts
Browse files

Deprecate the ghc-pkg --auto-ghci-libs flag

It was never a universal solution. It only worked with the GNU linker.
It has not been used by Cabal for ages. GHCi can now load .a files so
it will not be needed in future.
parent 6ef41c26
......@@ -642,6 +642,9 @@ registerPackage input verbosity my_flags auto_ghci_libs expand_env_vars update f
db_to_operate_on = my_head "register" $
filter ((== to_modify).location) db_stack
--
when (auto_ghci_libs && verbosity >= Silent) $
warn "Warning: --auto-ghci-libs is deprecated and will be removed in GHC 7.4"
--
s <-
case input of
"-" -> do
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment