Commit a9566632 authored by Takenobu Tani's avatar Takenobu Tani Committed by Marge Bot
Browse files

configure: Modify ERROR to WARN for sphinx's python check

If sphinx's python version check failed, many people prefer to build
without documents instead of stopping on the error.

So this commit fixes the following:

* Modify AC_MSG_ERROR to AC_MSG_WARN
* Add clearing of SPHINXBUILD variable when check fails

See also !2016.
parent fa0b1b4b
Pipeline #12349 passed with stages
in 591 minutes and 25 seconds
...@@ -842,7 +842,8 @@ FP_COMPARE_VERSIONS([$fp_cv_sphinx_version],-lt,1.0.0, ...@@ -842,7 +842,8 @@ FP_COMPARE_VERSIONS([$fp_cv_sphinx_version],-lt,1.0.0,
[AC_MSG_WARN([Sphinx version 1.0.0 or later is required to build documentation]); SPHINXBUILD=;]) [AC_MSG_WARN([Sphinx version 1.0.0 or later is required to build documentation]); SPHINXBUILD=;])
if test -n "$SPHINXBUILD"; then if test -n "$SPHINXBUILD"; then
if "$SPHINXBUILD" -b text utils/check-sphinx utils/check-sphinx/dist > /dev/null 2>&1; then true; else if "$SPHINXBUILD" -b text utils/check-sphinx utils/check-sphinx/dist > /dev/null 2>&1; then true; else
AC_MSG_ERROR([Sphinx for python3 is required to build documentation.]) AC_MSG_WARN([Sphinx for python3 is required to build documentation.])
SPHINXBUILD=;
fi fi
fi fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment