Commit c5c72aaf authored by Herbert Valerio Riedel's avatar Herbert Valerio Riedel 🕺

Update containers submodule to v0.5.7.0 release

This is the designated release to go with GHC 8.0.1

This release doesn't need any warning-suppression flags anymore, so
remove those from mk/warnings.mk

/cc @foxik
parent e0e03d5b
Subproject commit 6405653480afa675eec804616547b8625244bc7c
Subproject commit d86ba69819e716d9ee021cf3b34ba7244f2e1649
......@@ -48,7 +48,6 @@ SRC_HC_WARNING_OPTS_STAGE2 += -Wnoncanonical-monad-instances
libraries/bytestring_dist-install_EXTRA_HC_OPTS += -Wno-inline-rule-shadowing
# Turn off import warnings for bad unused imports
libraries/containers_dist-install_EXTRA_HC_OPTS += -Wno-unused-imports
libraries/bytestring_dist-install_EXTRA_HC_OPTS += -Wno-unused-imports
utils/haddock_dist_EXTRA_HC_OPTS += -Wno-unused-imports
libraries/vector_dist-install_EXTRA_HC_OPTS += -Wno-unused-imports
......@@ -56,10 +55,6 @@ libraries/vector_dist-install_EXTRA_HC_OPTS += -Wno-unused-imports
# haddock's attoparsec uses deprecated `inlinePerformIO`
utils/haddock_dist_EXTRA_HC_OPTS += -Wno-deprecations
# containers uses bitSize at the moment
libraries/containers_dist-install_EXTRA_HC_OPTS += -Wno-deprecations
libraries/containers_dist-install_EXTRA_HC_OPTS += -Wno-redundant-constraints
# On Windows, there are also some unused import warnings
ifeq "$(HostOS_CPP)" "mingw32"
libraries/time_dist-install_EXTRA_HC_OPTS += -Wno-unused-imports -Wno-identities
......
package01e.hs:2:1:
package01e.hs:2:1: error:
Failed to load interface for ‘Data.Map’
It is a member of the hidden package ‘containers-0.5.6.3’.
It is a member of the hidden package ‘containers-0.5.7.0’.
Use -v to see a list of the files searched for.
package01e.hs:3:1:
package01e.hs:3:1: error:
Failed to load interface for ‘Data.IntMap’
It is a member of the hidden package ‘containers-0.5.6.3’.
It is a member of the hidden package ‘containers-0.5.7.0’.
Use -v to see a list of the files searched for.
......@@ -6,7 +6,7 @@ TYPE CONSTRUCTORS
COERCION AXIOMS
Dependent modules: []
Dependent packages: [array-0.5.1.0, base-4.9.0.0, binary-0.8.0.0,
bytestring-0.10.7.0, containers-0.5.6.3, deepseq-1.4.2.0,
bytestring-0.10.7.0, containers-0.5.7.0, deepseq-1.4.2.0,
ghc-boot-0.0.0.0, ghc-prim-0.5.0.0, integer-gmp-1.0.0.0,
pretty-1.1.3.2, template-haskell-2.11.0.0]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment