Commit d8c89026 authored by Herbert Valerio Riedel's avatar Herbert Valerio Riedel 🕺

First pass at cleaning up ghci.cabal

This prepares the meta-data of the new `ghci` package for Hackage
parent 64b6a760
......@@ -2,7 +2,6 @@
{-# LANGUAGE MultiParamTypeClasses #-}
{-# LANGUAGE FlexibleInstances #-}
{-# LANGUAGE BangPatterns #-}
{-# LANGUAGE CPP #-}
{-# LANGUAGE MagicHash #-}
{-# LANGUAGE UnboxedTuples #-}
{-# LANGUAGE RecordWildCards #-}
......
## 8.0.1 *Feb 2016*
* Bundled with GHC 8.0.1
* Initial version
Name: ghci
Version: 0.0
Copyright: XXX
License: BSD3
-- XXX License-File: LICENSE
Author: XXX
Maintainer: XXX
Synopsis: XXX
Description:
name: ghci
version: 0
license: BSD3
license-file: LICENSE
category: GHC
maintainer: ghc-devs@haskell.org
bug-reports: https://ghc.haskell.org/trac/ghc/newticket
synopsis: XXX
description:
XXX
Category: Development
build-type: Simple
cabal-version: >=1.10
build-type: Simple
extra-source-files: changelog.md
source-repository head
type: git
location: http://git.haskell.org/ghc.git
subdir: libraries/ghci
Library
Default-Language: Haskell2010
Exposed-Modules: GHCi.Message,
library
default-language: Haskell2010
other-extensions:
BangPatterns
CPP
DeriveGeneric
ExistentialQuantification
FlexibleInstances
GADTs
GeneralizedNewtypeDeriving
InstanceSigs
MagicHash
MultiParamTypeClasses
RecordWildCards
ScopedTypeVariables
StandaloneDeriving
TupleSections
UnboxedTuples
exposed-modules:
GHCi.Message,
GHCi.ResolvedBCO,
GHCi.RemoteTypes,
GHCi.ObjLink,
......@@ -26,16 +49,18 @@ Library
GHCi.TH,
GHCi.TH.Binary,
SizedSeq
Build-Depends: base >= 4 && < 5,
binary >= 0.7 && < 0.9,
bytestring >= 0.10 && < 0.11,
containers >= 0.5 && < 0.6,
deepseq >= 1.4 && < 1.5,
filepath >= 1.4 && < 1.5,
ghc-boot,
array >= 0.5 && < 0.6,
template-haskell >= 2.11 && < 2.12,
transformers >= 0.4 && < 0.6
Build-Depends:
array == 0.5.*,
base == 4.9.*,
binary == 0.8.*,
bytestring == 0.10.*,
containers == 0.5.*,
deepseq == 1.4.*,
filepath == 1.4.*,
ghc-boot == 0.0.*,
template-haskell == 2.11.*,
transformers == 0.5.*
if !os(windows)
Build-Depends: unix >= 2.7 && < 2.8
Build-Depends: unix == 2.7.*
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment