Commit dfc021e7 authored by rrt's avatar rrt
Browse files

[project @ 2000-05-09 10:43:45 by rrt]

Changed Perl test so that it simply allows vv5 & 6 and disallows any other;
also hardwire path to perl to /bin/perl under Windows, to avoid clashing with
other weird Perls that may be on the path.
parent 272a1670
dnl $Id: aclocal.m4,v 1.46 1999/12/21 13:00:54 simonmar Exp $
dnl $Id: aclocal.m4,v 1.47 2000/05/09 10:43:45 rrt Exp $
dnl
dnl Extra autoconf macros for the Glasgow fptools
dnl
......@@ -319,26 +319,13 @@ dnl contains path to perl binary
dnl
AC_DEFUN(FPTOOLS_CHECK_PERL_VERSION,
[$PerlCmd -v >conftest.out 2>&1
if grep "version 4" conftest.out >/dev/null 2>&1; then
if grep "Patch level: 35" conftest.out >/dev/null 2>&1; then
echo "
************************************************************************
Uh-oh...looks like you have Perl 4.035.
Perl version 4.035 has a bug to do with recursion that will bite if
you run the lit2texi script, when making Info files from
literate files of various sorts. Either use perl5, the last version of perl4
(4.036), or an older version (e.g., perl 4.019). Failing that, don't create
any Info files :-)
************************************************************************
"
fi
if grep "version 5" conftest.out >/dev/null 2>&1; then
:
else
if grep "version 5" conftest.out >/dev/null 2>&1; then
if grep "version 6" conftest.out >/dev/null 2>&1; then
:
else
echo "I'm not sure if your version of perl will work,"
echo "but it's worth a shot, eh?"
echo "Your version of perl probably won't work."
fi
fi
rm -fr conftest*
......
......@@ -407,15 +407,27 @@ dnl --------------------------------------------------------------
dnl ** does #! work?
AC_SYS_INTERPRETER()
dnl ** look for `perl', but watch out for version 4.035
AC_PATH_PROG(PerlCmd,perl)
if test -z "$PerlCmd"; then
echo "You must install perl before you can continue"
echo "Perhaps it is already installed, but not in your PATH?"
exit 1
else
FPTOOLS_CHECK_PERL_VERSION
fi
dnl ** look for `perl', but only in /bin on Windows
case $HostOS_CPP in
cygwin32|mingw32)
AC_CHECK_PROG(PerlCmd,perl,/bin/perl,,/bin)
if test -z "$PerlCmd"; then
echo "You must install the version of Perl shipped with GHC"
echo "(or a compatible one) in /bin."
exit 1
fi
;;
*)
AC_PATH_PROG(PerlCmd,perl)
if test -z "$PerlCmd"; then
echo "You must install perl before you can continue"
echo "Perhaps it is already installed, but not in your PATH?"
exit 1
else
FPTOOLS_CHECK_PERL_VERSION
fi
;;
esac
dnl ** does #! path/to/perl work? (sometimes it's too long...)
FPTOOLS_SHEBANG_PERL
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment