Commit e580dd58 authored by Simon Marlow's avatar Simon Marlow

Fix bootstrap with 6.10.1 on Windows

ghc-pkg doesn't understand the old syntax any more, so 'ghc-pkg -l' fails
parent 3cb941fc
......@@ -927,6 +927,9 @@ AC_DEFUN([FP_PROG_GHC_PKG],
[fp_ghc_pkg_guess=`echo $WithGhc | sed 's,ghc\(@<:@^/\\@:>@*\)$,ghc-pkg\1,'`
if "$fp_ghc_pkg_guess" -l > /dev/null 2>&1; then
fp_cv_matching_ghc_pkg=$fp_ghc_pkg_guess
elif "$fp_ghc_pkg_guess" list > /dev/null 2>&1; then
# from 6.10, ghc-pkg doesn't support the old -l syntax any more
fp_cv_matching_ghc_pkg=$fp_ghc_pkg_guess
else
fp_cv_matching_ghc_pkg=no
fi])
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment