Commit 44169f4b authored by Alec Theriault's avatar Alec Theriault

Bump haddock-library to 1.7.0

The 1.6.1 release should've been a major bump, since types in
the `Documentation.Haddock.Parser.Monad` module changed. This version
makes that module internal (as it morally should be).
parent 37745e73
......@@ -44,7 +44,7 @@ library
, Cabal ^>= 2.4.0
, ghc ^>= 8.6
, ghc-paths ^>= 0.1.0.9
, haddock-library ^>= 1.6.1
, haddock-library ^>= 1.7.0
, xhtml ^>= 3000.2.2
-- Versions for the dependencies below are transitively pinned by
......@@ -169,7 +169,7 @@ test-suite spec
build-depends: Cabal ^>= 2.4
, ghc ^>= 8.6
, ghc-paths ^>= 0.1.0.9
, haddock-library ^>= 1.6.1
, haddock-library ^>= 1.7.0
, xhtml ^>= 3000.2.2
, hspec >= 2.4.4 && < 2.6
, QuickCheck ^>= 2.11
......
## Changes in version 1.7.0
* Make `Documentation.Haddock.Parser.Monad` an internal module
## Changes in version 1.6.1
* Replace `attoparsec` with `parsec` (#799)
......
cabal-version: 2.0
name: haddock-library
version: 1.6.1
version: 1.7.0
synopsis: Library exposing some functionality of Haddock.
description: Haddock is a documentation-generation tool for Haskell
libraries. These modules expose some functionality of it
......@@ -35,14 +35,14 @@ library
Documentation.Haddock.Doc
Documentation.Haddock.Markup
Documentation.Haddock.Parser
Documentation.Haddock.Parser.Monad
Documentation.Haddock.Types
Documentation.Haddock.Utf8
other-modules:
Documentation.Haddock.Parser.Util
Documentation.Haddock.Parser.Monad
ghc-options: -funbox-strict-fields -Wall -fwarn-tabs -O2
ghc-options: -funbox-strict-fields -Wall -fwarn-tabs
if impl(ghc >= 8.0)
ghc-options: -Wcompat -Wnoncanonical-monad-instances -Wnoncanonical-monadfail-instances
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment