Commit 9701fb0e authored by Herbert Valerio Riedel's avatar Herbert Valerio Riedel 🕺

Make n-queens benchmark compatible with older GHCs

The change in 957b959d
caused n-queens to break with older versions of `base`
which still have `Foreign.unsafePerformIO` in place.
parent 81fac789
......@@ -11,13 +11,13 @@
-- Don't enable -optc-mfpmath=sse -optc-msse2, this triggers a gcc bug on x86
--
import Foreign
import Foreign (Ptr, Storable(..), plusPtr, mallocBytes)
import Foreign.Storable
import Foreign.Marshal.Alloc
import Data.IORef
import Control.Monad
import System.Environment
import System.IO.Unsafe
import System.IO.Unsafe (unsafePerformIO)
import Text.Printf
main = do
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment