• John Ericson's avatar
    Clamp down on dependencies: · e7621b8e
    John Ericson authored
    Previously:
    
     - "build-depends" entries on internal libraries with an explicit version
       range are an error.
    
    Now for all three of "build-tools", "tool-depends", and "build-depends":
    
     - Explicit versions ranges on internal components that are satisfied by
       the current package cause a warning.
    
     - Explicit version ranges on internal components are are not satisfied by
       the current package are an error.
    
    And additionally for "tool-depends":
    
     - dependencies on a non-existent executable in the current package are an
       error.
    e7621b8e
Cabal.cabal 12.1 KB