Commit 0ea8baeb authored by Duncan Coutts's avatar Duncan Coutts
Browse files

Put explicit lower bound on version of base

It does not build with ghc-6.4.2, missing Functor instance for Either.
parent acd00698
......@@ -67,7 +67,8 @@ Executable cabal
Distribution.Client.Win32SelfUpgrade
Paths_cabal_install
build-depends: Cabal >= 1.6 && < 1.7,
build-depends: base >= 2 && < 4,
Cabal >= 1.6 && < 1.7,
filepath >= 1.0,
network >= 1 && < 3,
HTTP >= 3000 && < 3002,
......@@ -76,7 +77,7 @@ Executable cabal
if flag(old-base)
build-depends: base < 3
else
build-depends: base >= 3 && < 4,
build-depends: base >= 3,
process >= 1 && < 1.1,
directory >= 1 && < 1.1,
pretty >= 1 && < 1.1,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment