Commit 0f00536c authored by Duncan Coutts's avatar Duncan Coutts
Browse files

Only report not using latest versions when using < latest

Rather than when /= latest. So we'll no longer report things like:

  hdevtools-0.1.0.6 (latest: 0.1.0.5) (new package)

We don't need to tell people they're not using the latest version when
they're actually using a later version than the one available (e.g.
it's installed locally and not available from the remote server).

Reported by bennofs
parent 3c2d0881
......@@ -578,7 +578,7 @@ printPlan dryRun verbosity plan sourcePkgDb = case plan of
showLatest :: ConfiguredPackage -> String
showLatest pkg = case mLatestVersion of
Just latestVersion ->
if pkgVersion /= latestVersion
if pkgVersion < latestVersion
then (" (latest: " ++ display latestVersion ++ ")")
else ""
Nothing -> ""
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment