Revert "Revert "Bump version.""

This reverts commit bacdf19b.

'hackage-security' has been updated. I tested that build works now.
parent bacdf19b
name: Cabal
version: 1.25.0.0
version: 2.1.0.0
copyright: 2003-2017, Cabal Development Team (see AUTHORS file)
license: BSD3
license-file: LICENSE
......
VERSION=1.25.0.0
VERSION=2.1.0.0
#KIND=devel
KIND=rc
......
-*-change-log-*-
1.25.x.x (current development version)
2.0.0.0 (current development version)
* Add CURRENT_PACKAGE_VERSION to cabal_macros.h (#4319)
* Dropped support for versions of GHC earlier than 6.12 (#3111).
* GHC compatibility window for the Cabal library has been extended
......
......@@ -4,7 +4,7 @@
}:
mkDerivation {
pname = "Cabal";
version = "1.25.0.0";
version = "2.1.0.0";
src = ./.;
libraryHaskellDepends = [
array base binary bytestring containers deepseq directory filepath
......
......@@ -13,7 +13,7 @@ import sphinx_rtd_theme
sys.path.insert(0, os.path.abspath('.'))
import cabaldomain
version = "1.25"
version = "2.1"
extensions = ['sphinx.ext.extlinks']
......
......@@ -1038,7 +1038,7 @@ The library section should contain the following fields:
The library section may also contain build information fields (see the
section on `build information`_).
Cabal 1.25 and later support "internal libraries", which are extra named
Cabal 2.0 and later support "internal libraries", which are extra named
libraries (as opposed to the usual unnamed library section). For
example, suppose that your test suite needs access to some internal
modules in your library, which you do not otherwise want to export. You
......
......@@ -724,7 +724,7 @@ The following settings control the behavior of the dependency solver:
.. cfg-field:: index-state: HEAD, unix-timestamp, ISO8601 UTC timestamp.
:synopsis: Use source package index state as it existed at a previous time.
:since: 1.25
:since: 2.0
:default: ``HEAD``
......
......@@ -24,9 +24,9 @@ build_script:
- Setup install
# hackage-repo-tool doesn't build on Windows:
# https://github.com/well-typed/hackage-security/issues/175
# - echo "" | ..\cabal install hackage-repo-tool --allow-newer=Cabal,time --constraint="Cabal == 1.25.0.0"
# - echo "" | ..\cabal install hackage-repo-tool --allow-newer=Cabal,time --constraint="Cabal == 2.1.0.0"
- cd ..\cabal-testsuite
- ghc --make -threaded -i Setup.hs -package Cabal-1.25.0.0
- ghc --make -threaded -i Setup.hs -package Cabal-2.1.0.0
- echo "" | ..\appveyor-retry ..\cabal install --only-dependencies --enable-tests
- Setup configure --user --ghc-option=-Werror --enable-tests
- Setup build
......
......@@ -233,8 +233,8 @@ NETWORK_VER="2.6.3.1"; NETWORK_VER_REGEXP="2\.[0-6]\."
# >= 2.0 && < 2.7
NETWORK_URI_VER="2.6.1.0"; NETWORK_URI_VER_REGEXP="2\.6\."
# >= 2.6 && < 2.7
CABAL_VER="1.25.0.0"; CABAL_VER_REGEXP="1\.25\.[0-9]"
# >= 1.25 && < 1.26
CABAL_VER="2.1.0.0"; CABAL_VER_REGEXP="2\.1\.[0-9]"
# >= 2.1 && < 2.2
TRANS_VER="0.5.2.0"; TRANS_VER_REGEXP="0\.[45]\."
# >= 0.2.* && < 0.6
MTL_VER="2.2.1"; MTL_VER_REGEXP="[2]\."
......
Name: cabal-install
Version: 1.25.0.0
Version: 2.1.0.0
Synopsis: The command-line interface for Cabal and Hackage.
Description:
The \'cabal\' command-line program simplifies the process of managing
......@@ -351,7 +351,7 @@ executable cabal
base16-bytestring >= 0.1.1 && < 0.2,
binary >= 0.5 && < 0.9,
bytestring >= 0.9 && < 1,
Cabal >= 1.25 && < 1.26,
Cabal >= 2.1 && < 2.2,
containers >= 0.4 && < 0.6,
cryptohash-sha256 >= 0.11 && < 0.12,
deepseq >= 1.3 && < 1.5,
......@@ -720,7 +720,7 @@ test-suite integration-tests2
default-language: Haskell2010
custom-setup
setup-depends: Cabal >= 1.25,
setup-depends: Cabal >= 2.1,
base,
process >= 1.1.0.1 && < 1.5,
filepath >= 1.3 && < 1.5
-*-change-log-*-
1.25.x.x (current development version)
2.0.0.0 (current development version)
* Removed the '--root-cmd' parameter of the 'install' command
(#3356).
* Deprecated 'cabal install --global' (#3356).
......
......@@ -7,7 +7,7 @@
}:
mkDerivation {
pname = "cabal-install";
version = "1.25.0.0";
version = "2.1.0.0";
src = ./.;
isLibrary = false;
isExecutable = true;
......
set -e
HACKAGE_REPO_TOOL_VERSION="0.1.1"
CABAL_VERSION="1.25.0.0"
CABAL_VERSION="2.1.0.0"
# ---------------------------------------------------------------------
# Timing / diagnostic output
......
......@@ -8,7 +8,7 @@ deploy() {
(cd cabal-website && git checkout --track -b gh-pages origin/gh-pages)
rm -rf cabal-website/doc
mkdir -p cabal-website/doc/html
mv dist-newstyle/build/Cabal-1.25.0.0/doc/html/Cabal \
mv dist-newstyle/build/Cabal-2.1.0.0/doc/html/Cabal \
cabal-website/doc/html/Cabal
(cd cabal-website && git add --all .)
(cd cabal-website && \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment