Commit 3c03ccce authored by Edward Z. Yang's avatar Edward Z. Yang
Browse files

Add a custom setup to cabal-install.



This custom setup ensures that if we are bootstrapping, we will
use the most recent version of Cabal.  (Without setup, cabal-install
will force usage of an old version of Cabal.)
Signed-off-by: default avatarEdward Z. Yang <ezyang@cs.stanford.edu>
parent 283f0af8
......@@ -426,3 +426,9 @@ test-suite integration-tests
ghc-options: -Wall
default-language: Haskell2010
custom-setup
setup-depends: Cabal >= 1.25,
base,
process >= 1.1.0.1 && < 1.5,
filepath >= 1.3 && < 1.5
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment