Commit 614bcb7e authored by Herbert Valerio Riedel's avatar Herbert Valerio Riedel 🕺 Committed by Oleg Grenrus

Fix spec-ver lower-bound for some 3.0 fields in `cabal check`

These are only supported properly starting with
cabal-version:3.0 (which has been enforced by
Hackage as well -- via this very patch).

See #6033 for details
parent 6760fa2c
......@@ -1287,7 +1287,7 @@ checkCabalVersion pkg =
[ prettyShow (Dependency name (eliminateMajorBoundSyntax versionRange) Set.empty)
| Dependency name versionRange _ <- depsUsingMajorBoundSyntax ]
, checkVersion [2,1] (any (not . null)
, checkVersion [3,0] (any (not . null)
(concatMap buildInfoField
[ asmSources
, cmmSources
......@@ -1296,7 +1296,7 @@ checkCabalVersion pkg =
PackageDistInexcusable $
"The use of 'asm-sources', 'cmm-sources', 'extra-bundled-libraries' "
++ " and 'extra-library-flavours' requires the package "
++ " to specify at least 'cabal-version: >= 2.1'."
++ " to specify at least 'cabal-version: 3.0'."
, checkVersion [2,5] (any (not . null) $ buildInfoField extraDynLibFlavours) $
PackageDistInexcusable $
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment