Commit 6b624050 authored by Oleg Grenrus's avatar Oleg Grenrus
Browse files
parent 32b01519
......@@ -144,16 +144,16 @@ flag bundled-binary-generic
library
build-depends:
base >= 4.4 && < 5,
array >= 0.1 && < 0.6,
base >= 4.5 && < 5,
bytestring >= 0.9 && < 1,
containers >= 0.4 && < 0.6,
deepseq >= 1.3 && < 1.5,
filepath >= 1 && < 1.5,
directory >= 1 && < 1.3,
directory >= 1.1 && < 1.3,
filepath >= 1.3 && < 1.5,
pretty >= 1.1 && < 1.2,
process >= 1.1.0.1 && < 1.4,
time >= 1.1 && < 1.6,
containers >= 0.1 && < 0.6,
array >= 0.1 && < 0.6,
pretty >= 1 && < 1.2,
bytestring >= 0.9
time >= 1.4 && < 1.6
if flag(bundled-binary-generic)
build-depends: binary >= 0.5 && < 0.7
......@@ -166,7 +166,7 @@ library
if !os(windows)
build-depends:
unix >= 2.0 && < 2.8
unix >= 2.5 && < 2.8
ghc-options: -Wall -fno-ignore-asserts -fwarn-tabs
......
......@@ -160,22 +160,22 @@ executable cabal
-- NOTE: when updating build-depends, don't forget to update version regexps
-- in bootstrap.sh.
build-depends:
array >= 0.1 && < 0.6,
base >= 4.3 && < 5,
array >= 0.4 && < 0.6,
base >= 4.5 && < 5,
bytestring >= 0.9 && < 1,
Cabal >= 1.23 && < 1.24,
containers >= 0.1 && < 0.6,
filepath >= 1.0 && < 1.5,
containers >= 0.4 && < 0.6,
filepath >= 1.3 && < 1.5,
HTTP >= 4000.1.5 && < 4000.3,
mtl >= 2.0 && < 3,
pretty >= 1 && < 1.2,
pretty >= 1.1 && < 1.2,
random >= 1 && < 1.2,
stm >= 2.0 && < 3,
time >= 1.1 && < 1.6,
time >= 1.4 && < 1.6,
zlib >= 0.5.3 && < 0.7
if flag(old-directory)
build-depends: directory >= 1 && < 1.2, old-time >= 1 && < 1.2,
build-depends: directory >= 1.1 && < 1.2, old-time >= 1 && < 1.2,
process >= 1.0.1.1 && < 1.1.0.2
else
build-depends: directory >= 1.2 && < 1.3,
......@@ -193,7 +193,7 @@ executable cabal
build-depends: Win32 >= 2 && < 3
cpp-options: -DWIN32
else
build-depends: unix >= 2.0 && < 2.8
build-depends: unix >= 2.5 && < 2.8
if arch(arm) && impl(ghc < 7.6)
-- older ghc on arm does not support -threaded
......@@ -279,7 +279,7 @@ test-suite integration-tests
build-depends: Win32 >= 2 && < 3
cpp-options: -DWIN32
else
build-depends: unix >= 2.0 && < 2.8
build-depends: unix >= 2.5 && < 2.8
if arch(arm)
cc-options: -DCABAL_NO_THREADED
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment