Commit 6c2eba7f authored by Mikhail Glushenkov's avatar Mikhail Glushenkov Committed by Edward Z. Yang
Browse files

Clarify our policy on cabal-install support window.

It wasn't clear what "three-year support window for cabal-install"
means re: self-upgrade.

[ci skip]
parent 648381f7
...@@ -147,11 +147,13 @@ Conventions ...@@ -147,11 +147,13 @@ Conventions
buildable out-of-the-box with the dependencies that shipped with GHC buildable out-of-the-box with the dependencies that shipped with GHC
for at least five years. The Travis CI checks this, so most for at least five years. The Travis CI checks this, so most
developers submit a PR to see if their code works on all these developers submit a PR to see if their code works on all these
versions of GHC. cabal-install must also be buildable on all versions of GHC. `cabal-install` must also be buildable on all
supported GHCs, although it does not have to be buildable supported GHCs, although it does not have to be buildable
out-of-the-box. Instead, the `cabal-install/bootstrap.sh` script out-of-the-box. Instead, the `cabal-install/bootstrap.sh` script
must be able to download and install all of the dependencies. (This must be able to download and install all of the dependencies (this
is also checked by CI!) is also checked by CI). Also, self-upgrade to the latest version
(i.e. `cabal install cabal-install`) must work with all versions of
`cabal-install` released during the last three years.
* `Cabal` has its own Prelude, in `Distribution.Compat.Prelude`, * `Cabal` has its own Prelude, in `Distribution.Compat.Prelude`,
that provides a compatibility layer and exports some commonly that provides a compatibility layer and exports some commonly
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment