Commit 7597a174 authored by Duncan Coutts's avatar Duncan Coutts
Browse files

Don't make cabal-install into a library just yet

At some point in the future we probably do want a library or two
but we should make that decision deliberately and think about the API
that we want to expose.

I understand the change was made not to expose a lib API but to avoid
compiling the modules twice for the test-suite. It is true that that's
annoying but we don't yet have support for private or "convenience"
libraries and installing it as an exposed lib is not what we want to do
at the moment.
parent 6dde3458
......@@ -34,11 +34,10 @@ Flag old-directory
description: Use directory < 1.2 and old-time
default: False
Library
ghc-options: -Wall -fwarn-tabs
if arch(arm)
cc-options: -DCABAL_NO_THREADED
Exposed-Modules:
executable cabal
main-is: Main.hs
ghc-options: -Wall -fwarn-tabs
other-modules:
Distribution.Client.BuildReports.Anonymous
Distribution.Client.BuildReports.Storage
Distribution.Client.BuildReports.Types
......@@ -109,7 +108,6 @@ Library
Distribution.Compat.FilePerms
Distribution.Compat.Semaphore
Distribution.Compat.Time
Other-Modules:
Paths_cabal_install
build-depends:
......@@ -139,34 +137,58 @@ Library
cpp-options: -DWIN32
else
build-depends: unix >= 1.0 && < 2.7
c-sources: cbits/getnumcores.c
Executable cabal
Main-Is: Main.hs
hs-source-dirs: src
ghc-options: -Wall -fwarn-tabs
if !arch(arm)
if arch(arm)
cc-options: -DCABAL_NO_THREADED
else
ghc-options: -threaded
build-depends: base >= 4 && < 5,
Cabal >= 1.17.0 && < 1.18,
cabal-install >= 1.17.0 && < 1.18,
directory >= 1 && < 1.3,
filepath >= 1.0 && < 1.4
c-sources: cbits/getnumcores.c
Test-Suite unit-tests
type: exitcode-stdio-1.0
main-is: UnitTests.hs
hs-source-dirs: tests
hs-source-dirs: tests, .
ghc-options: -Wall -fwarn-tabs
other-modules:
UnitTests.Distribution.Client.Targets
UnitTests.Distribution.Client.Dependency.Modular.PSQ
UnitTests.Distribution.Client.Sandbox
build-depends:
base,
array,
bytestring,
Cabal,
containers,
mtl,
network,
pretty,
process,
directory,
filepath,
stm,
time,
network,
HTTP,
zlib,
test-framework,
test-framework-hunit,
test-framework-quickcheck2,
HUnit,
QuickCheck (>= 2.5),
cabal-install,
Cabal
ghc-options: -Wall -fwarn-tabs
if !arch(arm)
ghc-options: -threaded
QuickCheck >= 2.5
if flag(old-directory)
build-depends: old-time
if os(windows)
build-depends: Win32
cpp-options: -DWIN32
else
build-depends: unix
if arch(arm)
cc-options: -DCABAL_NO_THREADED
else
ghc-options: -threaded
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment