Commit 940e7503 authored by Alp Mestanogullari's avatar Alp Mestanogullari Committed by Oleg Grenrus

more verbose error for the extra-dynamic-library-flavours check

parent b337d0be
......@@ -1277,12 +1277,12 @@ checkCabalVersion pkg =
++ " and 'extra-library-flavours' requires the package "
++ " to specify at least 'cabal-version: >= 2.1'."
{-
, checkVersion [2,5] (not . null $ buildInfoField extraDynLibFlavours) $
PackageDistInexcusable $
"The use of 'extra-dynamic-library-flavours' requires the package "
++ " to specify at least 'cabal-version: >= 2.5'."
-}
++ " to specify at least 'cabal-version: >= 2.5'. The flavours are: "
++ commaSep [ display flav
| flav <- buildInfoField extraDynLibFlavours ]
, checkVersion [2,1] (any (not . null)
(buildInfoField virtualModules)) $
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment