Commit 99238a23 authored by kristenk's avatar kristenk
Browse files

Document --install-base-libraries.

parent 21bd4497
......@@ -1710,6 +1710,21 @@ Most users generally won't need these.
The command line variant of this field is ``--(no-)strong-flags``.
.. cfg-field:: install-base-libraries: boolean
--install-base-libraries
--no-install-base-libraries
:synopsis: Allow cabal to install or upgrade any package.
:default: False
By default, the dependency solver doesn't allow ``base``,
``ghc-prim``, ``integer-simple``, ``integer-gmp``, and
``template-haskell`` to be installed or upgraded. This flag
removes the restriction.
The command line variant of this field is
``--(no-)install-base-libraries``.
.. cfg-field:: cabal-lib-version: version
--cabal-lib-version=version
:synopsis: Version of Cabal library used to build package.
......
......@@ -32,6 +32,8 @@
* Support the Nix package manager (#3651).
* Made the 'template-haskell' package non-upgradable again (#4185).
* Fixed password echoing on MinTTY (#4128).
* Added a new solver flag, '--install-base-libraries', that allows
any package to be installed or upgraded (#4209).
1.24.0.0 Ryan Thomas <ryan@ryant.org> March 2016
* If there are multiple remote repos, 'cabal update' now updates
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment