Commit b6237a61 authored by ttuegel's avatar ttuegel Committed by GitHub
Browse files

Merge pull request #3833 from ttuegel/drop-ghc74-travis

Drop support for GHC 7.4
parents 1fcc8042 c9650198
......@@ -13,9 +13,6 @@ matrix:
os: linux
# These don't have -dyn/-prof whitelisted yet, so we have to
# do the old-style installation
- env: GHCVER=7.4.2 SCRIPT=script
os: linux
sudo: required
- env: GHCVER=7.6.3 SCRIPT=script
os: linux
sudo: required
......
......@@ -17,10 +17,6 @@ module Distribution.Compat.Binary
#endif
) where
#if __GLASGOW_HASKELL__ < 706
import Prelude hiding (catch)
#endif
import Control.Exception (catch, evaluate)
#if __GLASGOW_HASKELL__ >= 711
import Control.Exception (pattern ErrorCall)
......
......@@ -51,13 +51,6 @@ getEnvironment = fmap upcaseVars System.getEnvironment
getEnvironment = System.getEnvironment
#endif
#if __GLASGOW_HASKELL__ < 706
-- | @lookupEnv var@ returns the value of the environment variable @var@, or
-- @Nothing@ if there is no such value.
lookupEnv :: String -> IO (Maybe String)
lookupEnv name = (Just `fmap` System.getEnv name) `catchIO` const (return Nothing)
#endif /* __GLASGOW_HASKELL__ < 706 */
-- | @setEnv name value@ sets the specified environment variable to @value@.
--
-- Throws `Control.Exception.IOException` if either @name@ or @value@ is the
......
-*-change-log-*-
1.25.x.x (current development version)
* Dropped support for versions of GHC earlier than 6.12 (#3111).
* Dropped support for versions of GHC earlier than 7.6 (#3833).
* Convenience/internal libraries are now supported (#269).
An internal library is declared using the stanza "library
'libname'". Packages which use internal libraries can
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment