Commit c780e643 authored by Francesco Gazzetta's avatar Francesco Gazzetta

Clarify configConstraints backward compatibility

parent cbe1be34
......@@ -517,6 +517,9 @@ filterConfigureFlags flags cabalLibVersion
where
flags_latest = flags {
-- Cabal >= 1.19.1 uses '--dependency' and does not need '--constraint'.
-- Note: this is not in the wrong place. configConstraints gets
-- repopulated in flags_1_19_1 but it needs to be set to empty for
-- newer versions first.
configConstraints = []
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment