From d687543e6745e2dd172781a063b3d0876ca99cd5 Mon Sep 17 00:00:00 2001
From: ijones <ijones@syntaxpolice.org>
Date: Thu, 6 Jan 2005 05:02:41 +0000
Subject: [PATCH] cleaned and simplified makefiles to speed up build

---
 test/A/Makefile         | 19 +------------------
 test/HUnit-1.0/Makefile | 21 +--------------------
 test/Tests.mk           | 17 +++++++++++++++++
 test/wash2hs/Makefile   | 19 +------------------
 test/withHooks/Makefile | 19 +------------------
 5 files changed, 21 insertions(+), 74 deletions(-)
 create mode 100644 test/Tests.mk

diff --git a/test/A/Makefile b/test/A/Makefile
index a886712ebf..b97297a586 100644
--- a/test/A/Makefile
+++ b/test/A/Makefile
@@ -1,18 +1 @@
-all:
-	mkdir -p dist/tmp
-	ghc -cpp --make -odir dist/tmp -hidir dist/tmp -i../.. Setup.lhs -o setup
-clean:
-	rm -f setup a.out dist/build/testA
-	rm -rf ,tmp dist ,tmp2
-	find . -name "*.o" |xargs rm -f
-	find . -name "*.hi" |xargs rm -f
-check: all
-	./setup configure --user --prefix=/tmp/foo
-	./setup build
-	./setup install --install-prefix=/tmp/bar
-	ls /tmp/bar*
-	# install w/ register!
-	./setup install
-#	ls /tmp/foo*
-	./setup sdist
-	ls dist
+include ../Tests.mk
diff --git a/test/HUnit-1.0/Makefile b/test/HUnit-1.0/Makefile
index 28f401733c..b97297a586 100644
--- a/test/HUnit-1.0/Makefile
+++ b/test/HUnit-1.0/Makefile
@@ -1,20 +1 @@
-all:
-	mkdir -p dist/tmp
-	ghc -cpp --make -odir dist/tmp -hidir dist/tmp -i../.. Setup.lhs -o setup
-semiclean:
-	rm -rf ,tmp dist
-	find . -name "*.o" |xargs rm -f
-	find . -name "*.hi" |xargs rm -f
-clean: semiclean
-	rm -f setup a.out hunitTest
-	rm -f installed-pkg-config
-
-check: all
-	./setup configure --user --prefix=/tmp/foo
-	./setup install --install-prefix=/tmp/bar
-	ls /tmp/bar*
-	# install w/ register!
-	./setup install
-#	ls /tmp/foo*
-	./setup sdist
-	ls dist
+include ../Tests.mk
diff --git a/test/Tests.mk b/test/Tests.mk
new file mode 100644
index 0000000000..a710704444
--- /dev/null
+++ b/test/Tests.mk
@@ -0,0 +1,17 @@
+all:
+	ghc -cpp --make -i../.. Setup.lhs -o setup
+clean:
+	rm -f setup a.out
+	rm -rf ,tmp* dist
+	find . -name "*.o" |xargs rm -f
+	find . -name "*.hi" |xargs rm -f
+check: all
+	./setup configure --user --prefix=/tmp/foo
+	./setup build
+	./setup install --install-prefix=/tmp/bar
+	ls /tmp/bar*
+	# install w/ register!
+	./setup install
+#	ls /tmp/foo*
+	./setup sdist
+	ls dist
diff --git a/test/wash2hs/Makefile b/test/wash2hs/Makefile
index b7b84b9855..b97297a586 100644
--- a/test/wash2hs/Makefile
+++ b/test/wash2hs/Makefile
@@ -1,18 +1 @@
-all:
-	mkdir -p dist/tmp
-	ghc -cpp --make -odir dist/tmp -hidir dist/tmp -i../.. Setup.lhs -o setup
-clean:
-	rm -f setup
-	rm -rf ,tmp dist ,tmp2
-	find . -name "*.o" |xargs rm -f
-	find . -name "*.hi" |xargs rm -f
-check: all
-	./setup configure --user --prefix=/tmp/foo
-	./setup build
-	./setup install --install-prefix=/tmp/bar
-	ls /tmp/bar*
-	# install w/ register!
-	./setup install
-#	ls /tmp/foo*
-	./setup sdist
-	ls dist
+include ../Tests.mk
diff --git a/test/withHooks/Makefile b/test/withHooks/Makefile
index a886712ebf..b97297a586 100644
--- a/test/withHooks/Makefile
+++ b/test/withHooks/Makefile
@@ -1,18 +1 @@
-all:
-	mkdir -p dist/tmp
-	ghc -cpp --make -odir dist/tmp -hidir dist/tmp -i../.. Setup.lhs -o setup
-clean:
-	rm -f setup a.out dist/build/testA
-	rm -rf ,tmp dist ,tmp2
-	find . -name "*.o" |xargs rm -f
-	find . -name "*.hi" |xargs rm -f
-check: all
-	./setup configure --user --prefix=/tmp/foo
-	./setup build
-	./setup install --install-prefix=/tmp/bar
-	ls /tmp/bar*
-	# install w/ register!
-	./setup install
-#	ls /tmp/foo*
-	./setup sdist
-	ls dist
+include ../Tests.mk
-- 
GitLab