Commit e614f721 authored by Edward Z. Yang's avatar Edward Z. Yang
Browse files

Revert "D.PD.Check: extra-doc-files only allowed when Cabal >= 1.18."

This causes filepath to not validate, which means GHC build doesn't
work. Annoying. Let's not for 8.0 series.

This reverts commit 0b458361.
parent a2b9ced8
......@@ -904,13 +904,6 @@ checkCabalVersion pkg =
++ "different modules then list the other ones in the "
++ "'other-languages' field."
, checkVersion [1,18]
(not . null $ extraDocFiles pkg) $
PackageDistInexcusable $
"To use the 'extra-doc-files' field the package needs to specify "
++ "at least 'cabal-version: >= 1.18'."
-- check use of reexported-modules sections
, checkVersion [1,21]
(maybe False (not.null.reexportedModules) (library pkg)) $
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment