Commit fe0c264b authored by ttuegel's avatar ttuegel
Browse files

Fix test interface detailed-0.9 with GHC 7.10

Fixes #2476. Cabal could not build detailed-0.9 test suites with GHC
7.10 because the wrong package key was being used to build the test
suite library.

TODO: We should add real multi-library support to Cabal!
parent a821ffc7
......@@ -390,7 +390,7 @@ testSuiteLibV09AsLibAndExe pkg_descr
(package pkg) [] []
}
ipkgid = inplacePackageId (packageId pkg)
ipi = inplaceInstalledPackageInfo pwd distPref pkg ipkgid lib lbi libClbi
ipi = inplaceInstalledPackageInfo pwd distPref pkg ipkgid lib lbi' libClbi
testDir = buildDir lbi </> stubName test
</> stubName test ++ "-tmp"
testLibDep = thisPackageVersion $ package pkg
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment