This project is mirrored from https://github.com/haskell/Cabal. Pull mirroring updated .
  1. 07 Jun, 2009 10 commits
  2. 04 Jun, 2009 4 commits
  3. 05 Jun, 2009 4 commits
  4. 04 Apr, 2009 1 commit
  5. 29 Mar, 2009 1 commit
  6. 24 Mar, 2009 1 commit
  7. 03 Jun, 2009 1 commit
  8. 01 Jun, 2009 5 commits
  9. 31 May, 2009 7 commits
  10. 30 May, 2009 6 commits
    • Duncan Coutts's avatar
      Simplify version ranges before printing in configure error message · 0a0ff024
      Duncan Coutts authored
      Part of ticket #369. Now instead of:
        setup: At least the following dependencies are missing:
        base <3 && <4 && <3 && <3 && <4
      we get:
        setup: At least the following dependencies are missing:
        base <3
      0a0ff024
    • Duncan Coutts's avatar
      cf1ea287
    • Duncan Coutts's avatar
      Minor renaming · 0752390b
      Duncan Coutts authored
      Part of one of Stephen Blackheath's patches
      0752390b
    • Duncan Coutts's avatar
      Improve an internal error message slightly · e0ee8942
      Duncan Coutts authored
      e0ee8942
    • Duncan Coutts's avatar
      Detect intra-package build-depends · 3600d6cb
      Duncan Coutts authored
      Based on an original patch by Stephen Blackheath
      With this change build-depends on a library within the same package
      are detected. Such deps are not full handled yet so for the moment
      they are explicitly banned, however this is another step towards
      actually supporting such dependencies. In particular deps on
      internal libs are resolved to the internal one in preference to any
      existing external version of the same lib.
      3600d6cb
    • Duncan Coutts's avatar
      Use accurate per-component package deps · 94a08f98
      Duncan Coutts authored
      Based on an original patch by Stephen Blackheath
      Previously each component got built using the union of all package
      deps of all components in the entire package. Now we use exactly the
      deps specified for that component. To prevent breaking old packages
      that rely on the sloppy behaviour, package will only get the new
      behaviour if they specify they need at least cabal-version: >= 1.7.1
      94a08f98