This project is mirrored from https://github.com/haskell/Cabal. Pull mirroring updated .
  1. 13 Sep, 2013 1 commit
  2. 09 Sep, 2013 1 commit
  3. 18 Mar, 2013 1 commit
  4. 03 Nov, 2012 1 commit
  5. 23 Aug, 2012 1 commit
  6. 23 Oct, 2011 1 commit
  7. 19 Jun, 2011 1 commit
  8. 11 Oct, 2010 1 commit
  9. 15 Jun, 2010 1 commit
  10. 02 Jun, 2010 1 commit
    • Duncan Coutts's avatar
      Fix QA check on version range syntax to detect use of ()'s · f9a786c0
      Duncan Coutts authored
      The problem was that we do the QA check on using the new version range
      syntax after parsing. The new syntax allows ()'s but previously the
      code threw them away in the parser stage. We now retain them in the
      AST and deal with them appropriately. This now allows the QA check to
      be accurate and detect things like "build-depends: base (>= 4.2)".
      f9a786c0
  11. 21 Oct, 2009 1 commit
  12. 20 Sep, 2009 2 commits
  13. 17 Sep, 2009 2 commits
  14. 11 Sep, 2009 1 commit
  15. 10 Jul, 2009 1 commit
  16. 10 Dec, 2008 5 commits
  17. 08 Dec, 2008 1 commit
  18. 07 Dec, 2008 1 commit
  19. 05 Dec, 2008 1 commit
  20. 02 Dec, 2008 5 commits
  21. 28 Nov, 2008 1 commit
  22. 29 Jul, 2008 1 commit
  23. 28 Jun, 2008 1 commit
    • Duncan Coutts's avatar
      Update module headers · 0c993c84
      Duncan Coutts authored
      Use cabal-devel@haskell.org as the maintainer in most cases except for
      a few which were pre-existing modules copied from elsewhere or modules
      like L.H.Extension which really belong to libraries@haskell.org
      Remove the useless stability module. We have more detailed information
      on stability elsewhere (in the version number and user guide).
      Add more top level module documentation, taken from the source guide.
      0c993c84
  24. 26 Jun, 2008 1 commit
  25. 19 Jun, 2008 1 commit
    • Duncan Coutts's avatar
      Add version wildcard syntax · 5c562d13
      Duncan Coutts authored
        build-depends: foo ~1.2.*
      means:
        build-depends: foo >=1.2 && <1.3
      It's also valid everywhere else version ranges are used.
      5c562d13
  26. 29 May, 2008 2 commits
  27. 25 Mar, 2008 1 commit
  28. 21 Mar, 2008 1 commit
  29. 12 Mar, 2008 1 commit