Commit 3fafb06c authored by Herbert Valerio Riedel's avatar Herbert Valerio Riedel 🕺

Declare support for base-4.13

parent 34f9e98c
......@@ -64,7 +64,7 @@ library
Text.ParserCombinators.Parsec.Token
build-depends:
base >= 4.5.0 && < 4.13,
base >= 4.5.0 && < 4.14,
mtl >= 1.1.1 && < 2.3,
bytestring >= 0.9.2.1 && < 0.11,
text >= 0.11.3 && < 1.3
......
......@@ -271,7 +271,9 @@ instance Monad (ParsecT s u m) where
return = Applicative.pure
p >>= f = parserBind p f
(>>) = (Applicative.*>)
#if !MIN_VERSION_base(4,13,0)
fail = Fail.fail
#endif
-- | @since 3.1.12.0
instance Fail.MonadFail (ParsecT s u m) where
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment