Commit 5c079605 authored by Ben Gamari's avatar Ben Gamari 🐢
Browse files

Bump bootstrap compiler to GHC 8.10.7

parent 81f68e01
......@@ -57,7 +57,7 @@ let installDepsStep: CF.Type =
[ "apk add --no-cache ${Prelude.Text.concatSep " " buildDepends}" ]
let
ghcVersion: Text = "8.10.4"
ghcVersion: Text = "8.10.7"
let
fetchGhcStep: CF.Type =
......
......@@ -156,7 +156,7 @@ let images: List Image.Type =
{ name = "x86_64-linux-centos7"
, fromImage = "centos:7"
, runnerTags = [ "x86_64-linux" ]
, bootstrapGhc = { version = "8.10.4", triple = "x86_64-centos7-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "x86_64-centos7-linux" }
, llvm = None Llvm.Source
}
]
......
......@@ -189,7 +189,7 @@ let images: List Image.Type =
, fromImage = "arm64v8/debian:buster"
, runnerTags = [ "aarch64-linux" ]
, bootstrapLlvm = Some (Llvm.Source.FromBindist { version = "9.0.1" , triple = "aarch64-linux-gnu" })
, bootstrapGhc = { version = "8.10.4", triple = "aarch64-deb10-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "aarch64-deb10-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "11.0.1" , triple = "aarch64-linux-gnu" })
, cabalSource = Cabal.Type.FromBindist "http://home.smart-cactus.org/~ben/ghc/cabal-install-3.4.0.0-rc4-aarch64-linux.tar.xz"
, extraPackages = [ "libnuma-dev" ] : List Text
......@@ -201,7 +201,7 @@ let images: List Image.Type =
, fromImage = "arm32v7/debian:buster"
, runnerTags = [ "armv7-linux" ]
, bootstrapLlvm = Some (Llvm.Source.FromBindist { version = "9.0.1", triple = "armv7a-linux-gnueabihf" })
, bootstrapGhc = { version = "8.10.4", triple = "armv7-deb10-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "armv7-deb10-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "11.0.1" , triple = "armv7a-linux-gnueabihf" })
, cabalSource = Cabal.Type.FromBindist "http://home.smart-cactus.org/~ben/ghc/cabal-install-3.4.0.0-rc4-armv7l-deb10.tar.xz"
, extraPackages = [ "libnuma-dev" ] # debianBuildDepends
......@@ -213,7 +213,7 @@ let images: List Image.Type =
, fromImage = "i386/debian:stretch"
, runnerTags = [ "x86_64-linux" ]
, bootstrapLlvm = None Llvm.Source
, bootstrapGhc = { version = "8.10.4", triple = "i386-deb9-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "i386-deb9-linux" }
, llvm = None Llvm.Source
, cabalSource = Cabal.Type.FromBindist "https://downloads.haskell.org/~cabal/cabal-install-3.2.0.0/cabal-install-3.2.0.0-i386-unknown-linux.tar.xz"
, extraPackages = debianBuildDepends # [ "cabal-install" ] : List Text
......@@ -241,7 +241,7 @@ let images: List Image.Type =
, fromImage = "amd64/debian:buster"
, runnerTags = [ "x86_64-linux" ]
, bootstrapLlvm = Some (Llvm.Source.FromBindist { version = "9.0.1", triple = "x86_64-linux-gnu-ubuntu-16.04" })
, bootstrapGhc = { version = "8.10.4", triple = "x86_64-deb10-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "x86_64-deb10-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "11.0.1" , triple = "x86_64-linux-gnu-ubuntu-16.04" })
, cabalSource = Cabal.fromUpstreamBindist { version = "3.2.0.0", triple = "x86_64-unknown-linux" }
, extraPackages =
......@@ -256,7 +256,7 @@ let images: List Image.Type =
, fromImage = "amd64/debian:stretch"
, runnerTags = [ "x86_64-linux" ]
, bootstrapLlvm = None Llvm.Source
, bootstrapGhc = { version = "8.10.4", triple = "x86_64-deb9-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "x86_64-deb9-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "10.0.1" , triple = "x86_64-linux-gnu-ubuntu-16.04" })
, cabalSource = Cabal.fromUpstreamBindist { version = "3.2.0.0", triple = "x86_64-unknown-linux" }
, extraPackages = debianBuildDepends : List Text
......@@ -267,7 +267,7 @@ let images: List Image.Type =
, fromImage = "amd64/ubuntu:20.04"
, runnerTags = [ "x86_64-linux" ]
, bootstrapLlvm = None Llvm.Source
, bootstrapGhc = { version = "8.10.4", triple = "x86_64-deb9-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "x86_64-deb9-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "11.0.1" , triple = "x86_64-linux-gnu-ubuntu-16.04" })
, cabalSource = Cabal.fromUpstreamBindist { version = "3.2.0.0", triple = "x86_64-unknown-linux" }
, extraPackages = ubuntuBuildDepends
......
......@@ -161,7 +161,7 @@ let images: List Image.Type =
, fromImage = "amd64/fedora:27"
, runnerTags = [ "x86_64-linux" ]
, bootstrapLlvm = None Llvm.Source
, bootstrapGhc = { version = "8.10.4", triple = "x86_64-fedora27-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "x86_64-fedora27-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "11.0.1" , triple = "x86_64-linux-gnu-ubuntu-16.04" })
, cabalSource = Cabal.fromUpstreamBindist { version = "3.2.0.0", triple = "x86_64-unknown-linux" }
, extraPackages = [] : List Text
......@@ -172,7 +172,7 @@ let images: List Image.Type =
, fromImage = "amd64/fedora:32"
, runnerTags = [ "x86_64-linux" ]
, bootstrapLlvm = None Llvm.Source
, bootstrapGhc = { version = "8.10.4", triple = "x86_64-fedora27-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "x86_64-fedora27-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "11.0.1" , triple = "x86_64-linux-gnu-ubuntu-16.04" })
, cabalSource = Cabal.fromUpstreamBindist { version = "3.2.0.0", triple = "x86_64-unknown-linux" }
, extraPackages = [] : List Text
......@@ -183,7 +183,7 @@ let images: List Image.Type =
, fromImage = "amd64/fedora:33"
, runnerTags = [ "x86_64-linux" ]
, bootstrapLlvm = None Llvm.Source
, bootstrapGhc = { version = "8.10.4", triple = "x86_64-fedora27-linux" }
, bootstrapGhc = { version = "8.10.7", triple = "x86_64-fedora27-linux" }
, llvm = Some (Llvm.Source.FromBindist { version = "11.0.1" , triple = "x86_64-linux-gnu-ubuntu-16.04" })
, cabalSource = Cabal.fromUpstreamBindist { version = "3.2.0.0", triple = "x86_64-unknown-linux" }
, extraPackages = [] : List Text
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment