configure.ac.in 5.52 KB
Newer Older
1 2 3 4 5 6
dnl
dnl Binary distribution configure script
dnl
#!/bin/sh
#

7
AC_INIT([The Glorious Glasgow Haskell Compilation System], [@ProjectVersion@], [glasgow-haskell-bugs@haskell.org], [ghc-AC_PACKAGE_VERSION])
8

9 10 11 12
dnl--------------------------------------------------------------------
dnl * Deal with arguments telling us gmp is somewhere odd
dnl--------------------------------------------------------------------

Ian Lynagh's avatar
Ian Lynagh committed
13
FP_GMP
14

15
bootstrap_target=@TargetPlatform@
16 17
FPTOOLS_SET_PLATFORM_VARS

18 19 20
# Requires FPTOOLS_SET_PLATFORM_VARS to be run first.
FP_FIND_ROOT

21
# ToDo: if Stage1Only=YES, should be YES
22 23 24 25
CrossCompiling=NO
CrossCompilePrefix=""
TargetPlatformFull="${target}"

26
AC_SUBST(CrossCompiling)
27 28 29
AC_SUBST(CrossCompilePrefix)
AC_SUBST(TargetPlatformFull)

30 31 32
Unregisterised="@Unregisterised@"
AC_SUBST(Unregisterised)

33
#
34 35 36 37 38 39 40
dnl ** Check Perl installation **
#
AC_PATH_PROG(PerlCmd,perl)
if test -z "$PerlCmd"; then
   echo "You must install perl before you can continue"
   echo "Perhaps it is already installed, but not in your PATH?"
   exit 1
41 42
fi

sof's avatar
sof committed
43 44
#
dnl ** figure out how to do a BSD-ish install **
45 46
#
AC_PROG_INSTALL
sof's avatar
sof committed
47 48 49 50

#
dnl ** how to do symlinks **
#
sof's avatar
sof committed
51
AC_PROG_LN_S()
sof's avatar
sof committed
52 53 54

#
dnl ** Find the path to sed **
55
#
Ian Lynagh's avatar
Ian Lynagh committed
56
AC_PATH_PROG(SedCmd,gsed sed,sed)
57

58
XCODE_VERSION()
59 60 61

dnl ** Which gcc to use?
dnl --------------------------------------------------------------
62
AC_PROG_CC([gcc clang])
63

64 65
# --with-hs-cpp/--with-hs-cpp-flags
FP_CPP_CMD_WITH_ARGS(HaskellCPPCmd, HaskellCPPArgs)
thomie's avatar
thomie committed
66 67
AC_SUBST([HaskellCPPCmd])
AC_SUBST([HaskellCPPArgs])
68

69 70 71 72 73 74 75 76
# Here is where we re-target which specific version of the LLVM
# tools we are looking for. In the past, GHC supported a number of
# versions of LLVM simultaneously, but that stopped working around
# 3.5/3.6 release of LLVM.
LlvmVersion=@LlvmVersion@

dnl ** Which LLVM llc to use?
dnl --------------------------------------------------------------
Ben Gamari's avatar
Ben Gamari committed
77
FIND_LLVM_PROG([LLC], [llc], [$LlvmVersion])
78 79 80 81 82
LlcCmd="$LLC"
AC_SUBST([LlcCmd])

dnl ** Which LLVM opt to use?
dnl --------------------------------------------------------------
Ben Gamari's avatar
Ben Gamari committed
83
FIND_LLVM_PROG([OPT], [opt], [$LlvmVersion])
84 85 86
OptCmd="$OPT"
AC_SUBST([OptCmd])

87
FP_GCC_VERSION
Ben Gamari's avatar
Ben Gamari committed
88
FP_GCC_SUPPORTS_NO_PIE
89
AC_PROG_CPP
90

91 92 93
dnl ** Check gcc version and flags we need to pass it **
FP_GCC_EXTRA_FLAGS

94 95 96 97 98
FP_SET_CFLAGS_C99([CC],[CFLAGS],[CPPFLAGS])
dnl FP_SET_CFLAGS_C99([CC_STAGE0],[CONF_CC_OPTS_STAGE0],[CONF_CPP_OPTS_STAGE0])
FP_SET_CFLAGS_C99([CC],[CONF_CC_OPTS_STAGE1],[CONF_CPP_OPTS_STAGE1])
FP_SET_CFLAGS_C99([CC],[CONF_CC_OPTS_STAGE2],[CONF_CPP_OPTS_STAGE2])

99 100 101 102 103
FPTOOLS_SET_C_LD_FLAGS([target],[CFLAGS],[LDFLAGS],[IGNORE_LINKER_LD_FLAGS],[CPPFLAGS])
FPTOOLS_SET_C_LD_FLAGS([build],[CONF_CC_OPTS_STAGE0],[CONF_GCC_LINKER_OPTS_STAGE0],[CONF_LD_LINKER_OPTS_STAGE0],[CONF_CPP_OPTS_STAGE0])
FPTOOLS_SET_C_LD_FLAGS([target],[CONF_CC_OPTS_STAGE1],[CONF_GCC_LINKER_OPTS_STAGE1],[CONF_LD_LINKER_OPTS_STAGE1],[CONF_CPP_OPTS_STAGE1])
# Stage 3 won't be supported by cross-compilation
FPTOOLS_SET_C_LD_FLAGS([target],[CONF_CC_OPTS_STAGE2],[CONF_GCC_LINKER_OPTS_STAGE2],[CONF_LD_LINKER_OPTS_STAGE2],[CONF_CPP_OPTS_STAGE2])
104 105 106 107

AC_SUBST(CONF_CC_OPTS_STAGE0)
AC_SUBST(CONF_CC_OPTS_STAGE1)
AC_SUBST(CONF_CC_OPTS_STAGE2)
108 109 110 111 112 113 114 115 116
AC_SUBST(CONF_GCC_LINKER_OPTS_STAGE0)
AC_SUBST(CONF_GCC_LINKER_OPTS_STAGE1)
AC_SUBST(CONF_GCC_LINKER_OPTS_STAGE2)
AC_SUBST(CONF_LD_LINKER_OPTS_STAGE0)
AC_SUBST(CONF_LD_LINKER_OPTS_STAGE1)
AC_SUBST(CONF_LD_LINKER_OPTS_STAGE2)
AC_SUBST(CONF_CPP_OPTS_STAGE0)
AC_SUBST(CONF_CPP_OPTS_STAGE1)
AC_SUBST(CONF_CPP_OPTS_STAGE2)
117

118 119 120 121 122 123
dnl ** Which ld to use?
dnl --------------------------------------------------------------
FIND_LD([$target],[GccUseLdOpt])
CONF_GCC_LINKER_OPTS_STAGE1="$CONF_GCC_LINKER_OPTS_STAGE1 $GccUseLdOpt"
CONF_GCC_LINKER_OPTS_STAGE2="$CONF_GCC_LINKER_OPTS_STAGE2 $GccUseLdOpt"
LdCmd="$LD"
124
CFLAGS="$CFLAGS $GccUseLdOpt"
125 126 127 128 129 130 131
AC_SUBST([LdCmd])

FP_PROG_LD_IS_GNU
FP_PROG_LD_BUILD_ID
FP_PROG_LD_NO_COMPACT_UNWIND
FP_PROG_LD_FILELIST

132 133 134 135 136
dnl ** Set up the variables for the platform in the settings file.
dnl May need to use gcc to find platform details.
dnl --------------------------------------------------------------
FPTOOLS_SET_HASKELL_PLATFORM_VARS

137 138 139 140 141
dnl WordSize for settings.in
AC_CHECK_SIZEOF(void *, 4)
WordSize=$ac_cv_sizeof_void_p
AC_SUBST(WordSize)

Ian Lynagh's avatar
Ian Lynagh committed
142 143 144
#
dnl ** how to invoke `ar' and `ranlib'
#
145
FP_PROG_AR_SUPPORTS_ATFILE
Ian Lynagh's avatar
Ian Lynagh committed
146 147
FP_PROG_AR_NEEDS_RANLIB

Ben Gamari's avatar
Ben Gamari committed
148 149 150 151 152 153 154 155 156 157 158 159
dnl ** Have libdw?
dnl --------------------------------------------------------------
dnl Check for a usable version of libdw/elfutils
dnl Currently we need 0.158 or newer.
BinDistNeedsLibdw=@UseLibdw@
if test "x$BinDistNeedsLibdw" = "xYES" ; then
  AC_CHECK_LIB(dw, dwfl_attach_state,
    [UseLibdw=YES],
    [AC_MSG_ERROR([Binary distribution was built with libdw support but target system doesn't have supported libdw version (needs at least 0.158)])]
  )
fi

160 161
FP_SETTINGS

162
#
163
AC_CONFIG_FILES(settings mk/config.mk mk/install.mk)
164
AC_OUTPUT
165

166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184
# We get caught by
#     http://savannah.gnu.org/bugs/index.php?1516
#     $(eval ...) inside conditionals causes errors
# with make 3.80, so warn the user if it looks like they're about to
# try to use it.
# We would use "grep -q" here, but Solaris's grep doesn't support it.
checkMake380() {
    if $1 --version 2>&1 | head -1 | grep 'GNU Make 3\.80' > /dev/null
    then
        echo
        echo "WARNING: It looks like \"$1\" is GNU make 3.80."
        echo "This version cannot be used to build GHC."
        echo "Please use GNU make >= 3.81."
    fi
}

checkMake380 make
checkMake380 gmake

185
echo "****************************************************"
186
echo "Configuration done, ready to 'make install'"
sof's avatar
sof committed
187
echo "(see README and INSTALL files for more info.)"
188
echo "****************************************************"