• rl@cse.unsw.edu.au's avatar
    Make sure GCC uses the Sparc V9 instruction set · 1777f480
    rl@cse.unsw.edu.au authored
    We only support Sparc V9 and better as V8 lacks an atomic CAS instruction
    which we need for SMP. This means that we have to pass -mcpu=v9 to GCC when
    compiling and assembling. Hardcoding the flag is hackish but seems to be
    our best bet at the moment. It can still be overridden by the user as GCC
    picks the best -mcpu flag regardless of the ordering.
    1777f480
DriverPipeline.hs 49.9 KB