• audreyt@audreyt.org's avatar
    * Future-proof autoconf's Perl version test. · 4d245707
    audreyt@audreyt.org authored
      GHC only works with Perl versions 5.6 and later; however
      the current test greps in a rather non-future-proof way
      (explicitly against 5.6 and 5.8).
      
      We instead exploit the "v-string" change in 5.6, which
      displays the version string as "v5.x.y", rather than
      the earlier format "version 5.xxx_yyy".  Hence grepping
      against "v5" will make it future proof for a while.
      (At least until Perl 6 is installed as the system perl.)
    4d245707
aclocal.m4 37.8 KB