Commit 247e8ad1 authored by simonmar's avatar simonmar

[project @ 2003-08-14 15:43:22 by simonmar]

Don't require Alex for building GHC (yet).
parent ed10f282
dnl $Id: aclocal.m4,v 1.123 2003/08/13 13:35:07 simonmar Exp $
dnl $Id: aclocal.m4,v 1.124 2003/08/14 15:43:22 simonmar Exp $
dnl
dnl Extra autoconf macros for the Glasgow fptools
dnl
......@@ -291,10 +291,10 @@ else
fi;
changequote([, ])dnl
])
if test -d $srcdir/ghc -a ! -f $srcdir/ghc/compiler/parser/Lexer.hs; then
FPTOOLS_PROG_CHECK_VERSION([$fptools_cv_alex_version],-lt,[2.0],
[AC_MSG_ERROR([Alex version 2.0 or later is required to compile GHC.])])dnl
fi
dnl if test -d $srcdir/ghc -a ! -f $srcdir/ghc/compiler/parser/Lexer.hs; then
dnl FPTOOLS_PROG_CHECK_VERSION([$fptools_cv_alex_version],-lt,[2.0],
dnl [AC_MSG_ERROR([Alex version 2.0 or later is required to compile GHC.])])dnl
dnl fi
AlexVersion=$fptools_cv_alex_version;
AC_SUBST(AlexVersion)
])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment