Commit 27abb1f5 authored by Simon Marlow's avatar Simon Marlow
Browse files

put back -fwarn-depcrecations

It was replaced by -fwarn-warnings-deprecations, but I think we want
to keep it for backwards compatibility.  I'm not sure we want to
deprecate it either...
parent 33fd028c
...@@ -1492,6 +1492,7 @@ fFlags = [ ...@@ -1492,6 +1492,7 @@ fFlags = [
( "warn-unused-imports", Opt_WarnUnusedImports, const Supported ), ( "warn-unused-imports", Opt_WarnUnusedImports, const Supported ),
( "warn-unused-matches", Opt_WarnUnusedMatches, const Supported ), ( "warn-unused-matches", Opt_WarnUnusedMatches, const Supported ),
( "warn-warnings-deprecations", Opt_WarnWarningsDeprecations, const Supported ), ( "warn-warnings-deprecations", Opt_WarnWarningsDeprecations, const Supported ),
( "warn-deprecations", Opt_WarnWarningsDeprecations, const Supported ),
( "warn-deprecated-flags", Opt_WarnDeprecatedFlags, const Supported ), ( "warn-deprecated-flags", Opt_WarnDeprecatedFlags, const Supported ),
( "warn-orphans", Opt_WarnOrphans, const Supported ), ( "warn-orphans", Opt_WarnOrphans, const Supported ),
( "warn-tabs", Opt_WarnTabs, const Supported ), ( "warn-tabs", Opt_WarnTabs, const Supported ),
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment