Commit 2aea0294 authored by Simon Marlow's avatar Simon Marlow

Bump Happy requirement from 1.15 to 1.16

Now that the haskell98 dependency of GHC has been removed, the
Happy-generated parsers must import Data.Array rather than Array, and
that change was made in Happy 1.16.
parent d53090a3
......@@ -246,8 +246,8 @@ changequote([, ])dnl
])
if test ! -f compiler/parser/Parser.hs || test ! -f compiler/main/ParsePkgConf.hs || test ! -f compiler/cmm/CmmParse.hs || test ! -f compiler/parser/ParserCore.hs
then
FP_COMPARE_VERSIONS([$fptools_cv_happy_version],[-lt],[1.15],
[AC_MSG_ERROR([Happy version 1.15 or later is required to compile GHC.])])[]
FP_COMPARE_VERSIONS([$fptools_cv_happy_version],[-lt],[1.16],
[AC_MSG_ERROR([Happy version 1.16 or later is required to compile GHC.])])[]
fi
HappyVersion=$fptools_cv_happy_version;
AC_SUBST(HappyVersion)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment