Commit 8f3efaf7 authored by Ian Lynagh's avatar Ian Lynagh

Remove the windres configure check, now that we use an in-tree windres

parent 86f656f4
......@@ -289,45 +289,6 @@ AC_SUBST(AlexVersion)
])
dnl
dnl Check for windres and version.
dnl 2.15.91 works
dnl 2.17.50 doesn't work
dnl 2.18.50 works
dnl
AC_DEFUN([FPTOOLS_WINDRES],
[
if test "x$HostPlatform" = "xi386-unknown-mingw32"
then
AC_PATH_PROG(WindResCmd,windres,)
# Alex is passed to Cabal, so we need a native path
if test "${OSTYPE}" != "msys" && \
test "${WindResCmd}" != ""
then
# Canonicalise to <drive>:/path/to/gcc
WindResCmd=`cygpath -m ${WindResCmd}`
fi
AC_CACHE_CHECK([for version of windres], fptools_cv_windres_version,
changequote(, )dnl
[
if test x"$WindResCmd" != x
then
fptools_cv_windres_version="`$WindResCmd --version |
grep 'GNU windres' |
sed -e 's/GNU windres[^0-9]* \([0-9\.]*\).*/\1/g'`" ;
else
fptools_cv_windres_version="";
fi
changequote([, ])dnl
])
FP_COMPARE_VERSIONS([$fptools_cv_windres_version],[-eq],[2.17.50],
[AC_MSG_ERROR([Your windres version isn't compatible with GHC. 2.15.91 and 2.18.50 are known to work.])])[]
WindResVersion=$fptools_cv_windres_version;
AC_SUBST(WindResVersion)
fi
])
# FP_PROG_LD
# ----------
......
......@@ -568,9 +568,6 @@ if test "$BootingFromHc" = "NO"; then
FPTOOLS_ALEX
fi;
dnl Check we have an acceptable version of windres
FPTOOLS_WINDRES
dnl --------------------------------------------------
dnl ### program checking section ends here ###
dnl --------------------------------------------------
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment