Commit abb9fe1b authored by Ian Lynagh's avatar Ian Lynagh

We now tell the linker macosx_version_min is 10.5; trac #3521

We used to say 10.3, but this gives
    -rpath can only be used when targeting Mac OS X 10.5 or later 
when building shared libraries.
Patch from mwotton.
parent ba0e6b67
...@@ -1640,7 +1640,7 @@ linkDynLib dflags o_files dep_packages = do ...@@ -1640,7 +1640,7 @@ linkDynLib dflags o_files dep_packages = do
++ map SysTools.Option ( ++ map SysTools.Option (
md_c_flags md_c_flags
++ o_files ++ o_files
++ [ "-undefined", "dynamic_lookup", "-single_module", "-Wl,-macosx_version_min","-Wl,10.3", "-install_name " ++ (pwd </> output_fn) ] ++ [ "-undefined", "dynamic_lookup", "-single_module", "-Wl,-macosx_version_min","-Wl,10.5", "-install_name " ++ (pwd </> output_fn) ]
++ extra_ld_inputs ++ extra_ld_inputs
++ lib_path_opts ++ lib_path_opts
++ extra_ld_opts ++ extra_ld_opts
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment