Commit b374eb9c authored by Simon Marlow's avatar Simon Marlow
Browse files

Cabal depends on -package unix when GHC <= 6.2

parent 64f0661e
......@@ -24,6 +24,10 @@ SRC_HC_OPTS += -package directory
SRC_HC_OPTS += -package pretty
endif
ifeq "$(ghc_ge_603)" "NO"
SRC_HC_OPTS += -package unix
endif
# And similarly for when booting from .hc files:
HC_BOOT_LD_OPTS += -L$(GHC_COMPAT_DIR)
HC_BOOT_LIBS += -lghccompat
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment