Commit bc49cbd3 authored by Simon Marlow's avatar Simon Marlow
Browse files

Where we use $(GhcHcOpts), also add $(GhcStage1HcOpts)

This fixes building the compiler with -prof in $(GhcStage1HcOpts)
parent c1a31d0d
......@@ -41,7 +41,7 @@ UseGhcForCc = YES
# In this particular case, it turned out that -DDEBUG made Cabal
# import HUnit, which might not be installed for the compiler we are
# compiling with (e.g. 6.2.1). Hence the filter-out.
SRC_HC_OPTS += $(filter-out -D%, $(GhcHcOpts))
SRC_HC_OPTS += $(filter-out -D%, $(GhcHcOpts) $(GhcStage1HcOpts))
# GHC 6.4 didn't have WCsubst.c, but 6.4.1 did, and we need to know
# this in cbits/unicode.c The patchlevel isn't normally exposed as a
......
......@@ -15,7 +15,7 @@ include $(GHC_COMPAT_DIR)/compat.mk
# This is required because libghccompat.a must be built with
# $(GhcHcOpts) because it is linked to the compiler, and hence
# we must also build with $(GhcHcOpts) here:
SRC_HC_OPTS += $(GhcHcOpts)
SRC_HC_OPTS += $(GhcHcOpts) $(GhcStage1HcOpts)
ifeq "$(ghc_ge_504)" "NO"
SRC_HC_OPTS += -package lang -package util -package text
......
......@@ -13,7 +13,7 @@ include $(GHC_COMPAT_DIR)/compat.mk
# This is required because libghccompat.a must be built with
# $(GhcHcOpts) because it is linked to the compiler, and hence
# we must also build with $(GhcHcOpts) here:
SRC_HC_OPTS += $(GhcHcOpts)
SRC_HC_OPTS += $(GhcHcOpts) $(GhcStage1HcOpts)
HS_PROG = hsc2hs-bin
ifeq "$(HOSTPLATFORM)" "i386-unknown-mingw32"
......
......@@ -13,7 +13,7 @@ include $(GHC_COMPAT_DIR)/compat.mk
# This is required because libghccompat.a must be built with
# $(GhcHcOpts) because it is linked to the compiler, and hence
# we must also build with $(GhcHcOpts) here:
SRC_HC_OPTS += $(GhcHcOpts)
SRC_HC_OPTS += $(GhcHcOpts) $(GhcStage1HcOpts)
all :: runhaskell
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment