Commit ea78cd04 authored by simonmar's avatar simonmar

[project @ 2002-04-10 09:41:16 by simonmar]

Currently configure falls over if $srcdir/ghc exists and Happy >= 1.9
can't be found.  For a source distribution this is too paranoid,
because we ship the Happy-generated .hs files with the sources.  Now
we ignore a missing Happy if ghc/compiler/parser/Parser.hs exists,
which should be a reasonable heuristic.
parent 32c9a025
dnl $Id: aclocal.m4,v 1.98 2002/03/12 09:23:01 simonmar Exp $
dnl $Id: aclocal.m4,v 1.99 2002/04/10 09:41:16 simonmar Exp $
dnl
dnl Extra autoconf macros for the Glasgow fptools
dnl
......@@ -214,7 +214,7 @@ else
fi;
changequote([, ])dnl
])
if test -d $srcdir/ghc; then
if test -d $srcdir/ghc -a ! -f $srcdir/ghc/compiler/parser/Parser.hs; then
FPTOOLS_PROG_CHECK_VERSION([$fptools_cv_happy_version],-lt,[1.9],
[AC_MSG_ERROR([Happy version 1.9 or later is required to compile GHC.])])dnl
fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment