Commit 049481ee authored by panne's avatar panne

[project @ 2003-10-05 20:14:49 by panne]

Merged Ross' patch for Hugs:

Tweak to the FPTOOLS_HAVE_OPENGL: when testing for the GLUT lib,
include the GL/GLU/GLX libs just discovered.  While most platforms
don't require this, mysteriously some (e.g. OpenBSD) do.
parent 10b68ffe
...@@ -1057,7 +1057,9 @@ dnl and GL_X_LIBS/GLUT_X_LIBS. ...@@ -1057,7 +1057,9 @@ dnl and GL_X_LIBS/GLUT_X_LIBS.
GL_CFLAGS= GL_CFLAGS=
fi fi
LIBS="$GLUT_X_LIBS" dnl Keep the GL/GLU/GLX libs, but expand the rest to what GLUT needs.
dnl (Some systems, like OpenBSD, need the GL/GLU libs.)
LIBS=`echo "$LIBS" | sed "s@$GL_X_LIBS@$GLUT_X_LIBS@"`
FPTOOLS_SEARCH_LIBS([#include <GL/glut.h>], glutMainLoop, glut32 glut, have_glut=yes, have_glut=no) FPTOOLS_SEARCH_LIBS([#include <GL/glut.h>], glutMainLoop, glut32 glut, have_glut=yes, have_glut=no)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment