Commit 35e4455c authored by rrt's avatar rrt
Browse files

[project @ 2001-07-03 17:07:52 by rrt]

Kill --enable-minimal-unix-deps (now == mingw32) and emit an error if a
Cygwin compiler is detected.
parent 81461016
......@@ -429,20 +429,6 @@ if test x"$EnableWin32DLLs" = "xYES" ; then
AC_DEFINE(HAVE_WIN32_DLL_SUPPORT)
fi
dnl ** Building a Win32-friendlier compiler?
dnl --------------------------------------------------------------
AC_ARG_ENABLE(minimal-unix-deps,
[ --enable-minimal-unix-deps
Build a compiler that minimizes dependencies on Unix-like tools
under Win32, allowing the user to operate the compiler without
having to install Cygwin toolchain (say). (You still need
that toolchain to build GHC from sources though).
],
[MinimalUnixDeps=YES],
[MinimalUnixDeps=NO]
)
AC_SUBST(MinimalUnixDeps)
dnl ** Enable the building of the OpenGL/GLUT binding in hslibs?
dnl --------------------------------------------------------------
AC_ARG_ENABLE(hopengl,
......@@ -524,6 +510,9 @@ AC_PROG_CPP
dnl ** does the C compiler support the following options?
FPTOOLS_CC_FLAG(-mwin32,CC_SUPPORTS_MWIN32)
if test -n "$CC_SUPPORS_MWIN32"; then
AC_MSG_ERROR([A mingwin gcc is required to build GHC on Windows.])
fi
FPTOOLS_CC_FLAG(-mno-cygwin,CC_SUPPORTS_MNO_CYGWIN)
EXTRA_CC_OPTS="$CC_SUPPORTS_MNO_CYGWIN $CC_SUPPORTS_MWIN32"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment